Sayonara Player Forum
[0.9.3] Cannot install (arch) - Printable Version

+- Sayonara Player Forum (https://sayonara-player.com/forum)
+-- Forum: General Category (https://sayonara-player.com/forum/forum-3.html)
+--- Forum: Issues (https://sayonara-player.com/forum/forum-5.html)
+--- Thread: [0.9.3] Cannot install (arch) (/thread-244.html)



[0.9.3] Cannot install (arch) - whatever - 08-29-2017

It's impossible to install the player (v. 0.9.3) from aur. Issue:


Code:
[...]
[ 31%] Linking CXX static library libsay_gui_helper.a
[ 31%] Built target say_gui_helper
Scanning dependencies of target say_gui_covers_autogen
[ 31%] Generating ui_GUI_AlternativeCovers.h
[ 32%] Automatic MOC and UIC for target say_gui_covers
Generating MOC predefs moc_predefs.h
Generating MOC source EWIEGA46WW/moc_AlternativeCoverItemDelegate.cpp
Generating MOC source EWIEGA46WW/moc_AlternativeCoverItemModel.cpp
Generating MOC source EWIEGA46WW/moc_CoverButton.cpp
Generating MOC source EWIEGA46WW/moc_GUI_AlternativeCovers.cpp
Generating MOC compilation mocs_compilation.cpp
AutoUic: Error: "/tmp/yaourt-tmp-simon/aur-sayonara-player/src/sayonara-player/src/GUI/Covers/GUI_AlternativeCovers.cpp"
Could not find "GUI/Covers/GUI_AlternativeCovers.ui"

make[2]: *** [src/GUI/Covers/CMakeFiles/say_gui_covers_autogen.dir/build.make:60: src/GUI/Covers/CMakeFiles/say_gui_covers_autogen] Error 1
make[1]: *** [CMakeFiles/Makefile2:614: src/GUI/Covers/CMakeFiles/say_gui_covers_autogen.dir/all] Error 2
make: *** [Makefile:130: all] Error 2
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build sayonara-player.
==> Restart building sayonara-player ? [y/N]
==> ----------------------------------------
==>




Thank you for reading this.


RE: [0.9.3] Cannot install (arch) - Lucio Carreras - 08-29-2017

I am aware of this problem. This is due to a new Cmake version and some unclean coding. I'll try to fix that asapö

Thanks for the report


RE: [0.9.3] Cannot install (arch) - Lucio Carreras - 08-29-2017

Can you please tell me the output of
Code:
cmake --version

Thank you


RE: [0.9.3] Cannot install (arch) - whatever - 08-30-2017

It says:

Code:
cmake version 3.9.1

CMake suite maintained and supported by Kitware (kitware.com/cmake).


Should i downgrade?


RE: [0.9.3] Cannot install (arch) - Lucio Carreras - 08-31-2017

(08-30-2017, 04:52 AM)whatever Wrote: It says:

Code:
cmake version 3.9.1

CMake suite maintained and supported by Kitware (kitware.com/cmake).


Should i downgrade?

The Downgrade would make it work. If you can be patient until the weekend, it'll be fixed


RE: [0.9.3] Cannot install (arch) - whatever - 09-02-2017

Thanks, I've been busy, so I didn't do anything I'll try next week and then report here.


RE: [0.9.3] Cannot install (arch) - Lucio Carreras - 09-07-2017

I fixed that bug a few days ago and wrote to the arch linux maintainer.

If you wanna compile the current version yourself, use rhe arch-bsd-fixes branch.

Greetings,
Lucio


RE: [0.9.3] Cannot install (arch) - whatever - 09-10-2017

Thank you, I've installed it automatically using the latest cmake and works perfectly now. Very nice program btw Smile