Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Outdated dependencies?
#1
You can get the most recent version on the svn server (you have to install subversion)

Code:
git clone -b master https://git.sayonara-player.com/sayonara.git sayonara-player

There is also a source archive on the Sayonara homepage.

Libraries
  • Qt >= 5.3
  • Taglib
  • Gstreamer 1.0, Gstreamer base plugins, Gstreamer good plugins,
    Gstreamer ugly plugins (optional)
  • Cmake
  • G++ >= 4.8

apt-get
Code:
apt-get install cmake pkg-config qt5-default qttools5-dev qttools5-dev-tools \\
libqt5core5a libqt5network5 libqt5sql5 libqt5sql5-sqlite libqt5xml5 libtag1-dev \\
libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev  libsqlite3-0 libmtp-dev \\
gstreamer1.0-plugins-base gstreamer1.0-plugins-good

optional:
Code:
gstreamer1.0-plugins-ugly libmp3lame

yum
Code:
yum install gcc gcc-c++ cmake desktop-file-utils libappstream-glib qt5-qtbase-devel qt5-qttools-devel gstreamer1-plugins-base-devel \\
taglib-devel libmtp-devel

for gstreamer-plugins-ugly and lame mp3 encoder you need the rpmforge or rpmfusion package sources. After enabling these sources you can install the packages with

Code:
yum install gstreamer-plugins-ugly lame


Code:
mkdir -p build && cd build
cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=\"Release\"
make
make install (as root)

You also can use \"Debug\" for CMAKE_BUILD_TYPE

See here for a spec file for rpm based distributions: http://sayonara-player.com/sw/rpm/sayonara.spec

See here for a PKGBUILD file for Arch Linux: http://sayonara-player.com/sw/arch_linux/PKGBUILD


[Edited on 29-2-2016 by Lucio Carreras]
Reply
#2
The Debian package can be installed by
Code:
dpkg -i sayonara-***.deb
The dependency problem with qt core and taglib should be fixed now.

The RPM package has to be installed with the --force option due to some bug in CPack.
Code:
rpm -i sayonara-***.rpm --force

I will fix this as soon as possible
Reply
#3
At Ubuntu 12.04 I also had to install libtag1-dev to solve this:

-- checking for module \'taglib>=1.6\'
-- package \'taglib>=1.6\' not found

Reply
#4
For some compiling trouble (encountered under Linux Mint 15 based on Ubuntu 13.04):

libtaglib2.0-cil was replaced by libtaglib-cil-dev
Other depedencies needed: libtag1-dev (as vipseixas had written before) and libnotify-cil-dev

[Edited on 2-12-2013 by GeorgeB]
Pinky: Gee, Brain, what do you want to do tonight?
Brain: The same thing we do every night, Pinky - try to take over the world!
Reply
#5
Thank you. This error has been corrected
Reply
#6
Hi Lucio,

are the instructions (especially the dependencies) outdated?

As a reference I\'m using:
WebSVN/PKGBUILD

where we have some additional dependencies.

Regards,

Leonard
Reply
#7
Hi, no actually they are state of the art. Do you have any problems? The PKGBUILD is intended for Arch Linux. So the packages may vary.
Reply
#8
I\'m just wondering about:

forum:
Gstreamer
-base
-good
-ugly

vs PKGBUILD:
Gstreamer
-base
-good
-bad
optionally -ugly

So the PKGBUILD additionally lists bad and ugly only as optional whereas this forum post lists ugly as a hard dependeny (though I\'m not sure whether deb has soft-dependencies but I actually don\'t doubt that).

Regarding upstream the \"plugin-packages\" are the same across all distros if they did not actively changed them.
Reply
#9
I will change the PKGBUILD this evening. The bad plugins for gstreamer are not needed anymore and the ugly plugins remain optional, not mandatory.
Reply
#10
ah, ok. Thank you for clarification ;-)
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)