Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
[SOLVED] Load last track on startup option does not work
#1
The option \'Preferences \\ Start up \\ Load last track on startup\' does not work. Playback continues from the first item in the playlist. (0.3.2r564)

[Edited on 13-7-2013 by Kallisto]
Reply
#2
I cannot reproduce this issue. This only may happen if you kill sayonara via ctrl+c within 1 sek after you changed the track.
Reply
#3
I exit from the application with \'Close\' menu item of tray icon. In the preferences window checked the first 3 items: Load playlist on startup, Start playing, Load last track on startup. My music library is empty.

It seems, Sayonara saves current song correctly, \'last_track\' in ./Sayonara/player.db set to \'-1,<file name, which was played at the time of the application exit>\'. But for some reason, Sayonara start playing from the first item of the saved playlist.
Reply
#4
Aaaah, those are extern tracks not loaded from library. For these tracks I could reproduce the issue
Reply
#5
Done. Already on SVN, will be available in the next version
Reply
#6
sayonara-0.4.0-r695-x86_64.deb:

The playlist is not saved/restored on the application shutdown/restart if the library path is not set.

The application crashed on right mouse click on the empty playlist.
Reply
#7
Ok, this is a combination I didn\'t look at... Sad But now
Reply
#8
Uuuups... I forgot again to set the first 3 checkboxes under Preferences \\ Start Up. (I feed these options should be set by default, as this is a standard behavior for all other players.)
Now, I see the playlist is saved/restored, but there is some issue with the last song. A wrong song starts to play after restart of the application... It seems, the restored song is two items below the saved song in the playlist.
Reply
#9
After a series of restarts (I tried to catch relaunch problem) the issue is gone. I cannot reproduce it anymore. Sayonara plays the correct song after restart. I tried to delete .Sayonara directory, but still have no problem. Strange... Let\'s presume that was my local problem.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)